有的时候我们要开发一些简单的程序,会用到 线程_启动() 但是带参是比较麻烦的事情,这里有种简单的方法

.版本 2
.支持库 EThread

.子程序 _按钮1_被单击
.局部变量 文件号, 整数型

文件号 = 打开内存文件 ()
写出数据 (文件号, “传递的参数”)
启动线程 (&子程序1, 文件号, )

.子程序 子程序1
.参数 文件号, 整数型
.局部变量 a, 文本型

移到文件首 (文件号)
读入数据 (文件号, a)
输出调试文本 (a)

利用写到内存文件的方法, 拿到文件号, 再传递整数型文件号, 通过文件号再读取内存,拿到文本型参数。

拓展
如果是多个文本参数,可以使用文本拼接的方法, 再利用

文本_分割文本 (参数, “|”, , 参数组) 来重新取出即可

Last modification:October 14th, 2020 at 11:29 am
如果觉得我的文章对你有用,请随意赞赏